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Overview

‘CodeGen8’ is a program that maximizes the development efficiency by creating bug-free basic
source codes and projects in a s hort time for application S/ W developers who use AB OV’s 8051
products.
The CodeGen8 program creates the source codes and projects in a form that can be compiled using
a commercial compiler of KEIL and IAR.
The CodeGen8 program only operates in S/W without a separate H/W.

1.1

System requirements

The CodeGen8 requires one of the following operating systems:


Microsoft Windows Vista



Microsoft Windows 7



Microsoft Windows 8 & 8.1



Microsoft Windows 10 & later

As software, the CodeGen8 program can run on a basic PC, and does not require special
specifications.
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Installation

2.1

Program download

2. Installation

Users can download the installer at ABOV’s website. This is an ideal way for the users to always have
the latest version of the software, as ABOV continues to add new devices and features to its website.
The setup file’s name displays the version number and the date it was created. For ex ample, when
the setup file’s name is ”Setup_CodeGen8_V1.234.56(210912).exe”, it displays the following
information:


The installer is for the CodeGen8 programmer S/W package.



The installer’s version is 1.234.56. Each number separated by a period has the following
meaning:



━

Major version = 1

━

Minor version = 234,

━

Patch version = 56

It was released on September 12, 2021.

Once the CodeGen8 application is launched, it searches for a newer version from the ABOV website.
When the CodeGen8 program finds a newer version, it informs to users.
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Program installation

Once the program installation is finished, users see the message shown in Figure 1. The us ers can
run the installer without receiving a request for a software license nor a driver.

Figure 1 Run Downloaded Ins t aller
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How to use CodeGen8 program

3.1

Introduction

3. How to use CodeGen8 program

With just a few mouse clicks, the CodeGen8 program creates source codes and S/W projects , which
could be created through a variety of time-consuming processes such as knowing device specification,
understanding each peripheral’s operation, SFR structure and control methods, and specifying the I/O
pins.
While using the CodeGen8 program, developers can directly obtain the optimized project for a
compiler they are using (e.g. KEIL, IAR). Besides, the users need to remember the things below when
using the CodeGen8 program:


The CodeGen8 program does not include any compiler. Therefore users should ask the
corresponding company about the compiler.



The CodeGen8 program is very intuitive and easy for users to use, even if the users do not
read this document.
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P rogram start

When starting the program, users can see a dialog box as shown in Figure 2.
In the initial state, most buttons in the dialog box are disabled and remain in that state until users
create projects. If there are projects created previously, the users can import or erase the projects.
The procedure for creating a project is as follows:
1.

Set the target device for developing an application.
A.

Set the series name.

B.

Set the device name.

C.

Set the package type.

2.

Enter project name, then the ‘NEW project’ button is activated.

3.

Click on the ‘NEW project’ button to start a new project.

A project is automatically saved when the target project changes during the CodeGen8 operation or
when the program completes the operation. The saved project can be loaded for the following tasks.

Figure 2 P rojec t S elec t ion Dialog B ox
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3. 1.2
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P roject creation

If the user selects a project, the user can set the functions of the corresponding device on the
changed screen.
As shown in Figure 3, the screen displays not only source file names to be creat ed in the project
folder, but also header files and pin maps of the selected device and a pane where the user can set
the built-in peripherals.

Figure 3 CodeGen8 P rogram
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Menus

There are three menus in the ribbon menu: File, View, and Help.
3. 2.1

File

Figure 4 shows a ribbon menu when the ‘File’ menu is selected. Using the File menu, the users can
select a function regarding files and options of a project.

Figure 4 File Menu
The File menu includes the sub-menus listed below:


New or Load Project: It closes the project that the user is currently working on, and then
starts new project or loads a project that was saved previously. The project selection dialog
box (shown in Figure 2) is displayed again to allow the user to create a new project or load
an existing project.



Multi -> Single source/ Single -> Multi source: It changes a composition of a source file that
is created by the CodeGen8 program. For detailed information on this, please refer to 3. 2.1
File.



Generat e source file(s): It saves the source code and project as a f orm at of KEIL or IA R in a
hard disk.
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Users can select a format bet ween KEIL format and IA R format by clicking on the button
located top-right of the window as shown in Figure 5. This button t oggles KEIL format and
IAR format as the user clicks it.

Figure 5 Format S elec t ion bet ween K E IL and IA R
The files to be saved are as follows:



━

Project files for a specified compiler.

━

A device header file

━

Main program

━

A header file containing definitions of the initial functions of each peripheral

Call KEIL compiler/ Call IAR compiler: It saves sourc e codes and projects as a format of
KEIL or IA R in a hard disk, and then call the corresponding compiler. Please remember that
ABOV does not provide compilers.



Print…: It prints the specified files out.



Print Preview: It allows users to preview the corresponding files before outputting them to a
printer.



Print Setup…: It sets the printer to use.



Exit: It terminates the CodeGen8 program. Projects users are working on are automatically
saved.
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V iew

Figure 6 shows a ribbon menu when the ‘View’ menu is selected. Using the View menu, the users can
set the menu configuration and colors of the CodeGen8 program on the screen. Therefore, this menu
does not affect the code creation function even if it is not set.

Figure 6 V iew Menu
The View menu includes the sub-menus listed below:


Add vertical TAB group: It provides functionality for a tab control. The tab cont rol displays a
dockable window with flat or three -dimensional tabs at its top or bottom. The tabs can
display text and an image and can change color when active.



Toolbars and Docking Windows: It shows or hides various child views. If the us ers select
child views as shown in Figure 7, the selected child views open.

Figure 7 Child V iew S elec t ion


Status Bar: It turns the Status bar on or off.



Caption Bar: It turns the Caption bar on or off.



Application Look: It changes the CodeGen8 software’s GUI style at once.
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Figure 8 Menu E x t ens ion
3. 2.3

Help

Figure 9 shows a ribbon menu when t he ‘Help’ menu is selected. Using the Help menu, the users can
identify the CodeGen8 version and check copyright, generated data, and programmer.

Figure 9 Help Menu

Figure 10 A bout Dialog B ox

13

3. How to use CodeGen8 program

3.3

Control bars

3. 3.1

Tool bar
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The Tool bar is a control bar that implements frequently used functions in the form of buttons and
collects them. On the Tool bar, the users can start certain functions by simply clicking on the button
without opening a series of menus.

Figure 11 Help Menu: Tool B ar
3. 3.2

Capt ion bar

The Caption bar displays the device name, package type, project name and project target compiler
button.

Figure 12 Help Menu: Capt ion B ar
3. 3.3

S t atus bar

The Status bar displays information on the current state of the CodeGen8.

Figure 13 Help Menu: S t at us B ar
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3.4

Description of each pane

3. 4.1

File View pane

In this pane, files that are used or will be used in the Project are listed: Source file (*.c), Header file
(*.h), and other files that are requested.
As shown in Table 1, the created files differ depending on whether a user selects a Single-source file
project or a Multi-source file project. The Single-source file project is selected by default.
Table 1 shows the differenc e between the Single-source file project selection and Multi-source file
project selection. Each file opens when the user double-clicks on the file name.
Table 1 Dif f erenc e bet ween S ingle/ Mult i S ourc e File P rojec t s
S ingle s ource file project

Multi s ource file project



All codes are created in the main.c file.



The

main.c

includes

all

of

the

interrupts, peripheral initialize codes,
and call functions.



Each source c ode f or a f unction is
created.



The main.c includes only codes for the
call functions, and the interrupt and
peripheral initialize codes are created
in individual files, respectively.
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Tex t file pane

This pane shows the selected text file as shown in Figure 14. The file is created by the CodeGen8,
and does not support the edit function with user key inputs.
In the C-type source program, different colors are applied to each keyword to enhance readability.

Figure 14 Dev ic e S elec t ion
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3. 4.3

3. How to use CodeGen8 program

P ac kage pane

This pane displays packages of the selected device, and allows users to specify the initial s ett ings for
each pin.
To set a function on a pin in the Package pane, double click on the pin to open a dialog box for the pin
settings. When the pin completes to be set, it is displayed in a different color.

Figure 15 Load Hex File
Users can easily read the status of the pin because it is displayed in different colors.
Table 2 Def init ion of Color
P in c olor

Meaning

Red

This pin is a power source pin.

Blue

This pin is a ground pin.

White

This pin is not assigned function yet.

Yellow



This pin is assigned a specific function.



Assigned function text color changed to red.



Assigned pin list is displayed under package shape.
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P roperties pane

The Properties pane introduces the most important function of the CodeGen8 program, and is shown
in Figure 16.
In this pane, users can set the detailed initial status of built -in peripherals of the selected device.
Since each device has a different type and number of built-in peripherals, this pane displays different
configurations for each device.
Most of all, the Properties pane is designed intuitively allowing application developers to set the
necessary functions without any difficulties, even if the users are not familiar with the dat a book of the
device the users want to use.
If users select each sub-menu, related functions are expanded and displayed so that the users can
check or modify the value. The changed value in this pane is immediately applied to the source code
and updates the corresponding display.

Figure 16 P ropert ies P ane

18

CodeGen8 User Guide

3. 4.5

3. How to use CodeGen8 program

Out put pane

The Output pane displays a warning message of the device peripheral settings or conflictions. Users
must clear the warning message by changing the device peripheral settings. Otherwise, it creates C
source program that omits some peripheral settings.

Figure 17 Out put P ane
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Output files

3. 5.1

P roject files
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The project files created here are for the purpose of being identified by the compiler that developers
are using.
It includes the device information used when compiling source files (e.g.: memory map) and the path
information of the source files used by application software.
The CodeGen8 program creates project files for the 8051 compiler of KEIL and IAR.
3. 5.2

Header files

A header file includes the files below:


Description of peripheral address information of the target device. It consists of DEFINE
statements that can be used by KEIL or IAR.


3. 5.3

Basic definition of functions used for device initialization.
S ource f iles

A source file includes the files below:


Main.c: A main file of a C source program. It describes the overall flow of an application
program.



Description of peripheral initialization function of the t arget device. It describes functions that
reflect all values set by users using the CodeGen8 program.
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Revision history
V ersion

Dat e

Des cription

1.0.0

May. 2013

First release, Support KEIL project only.

1.0.1

Feb. 2019

Change program name from VPE to CodeGen8

1.0.2

Oct. 2021

Add IAR project generating feature
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ABOV Disclaim er
IMPORTANT NOTICE – PLEASE READ CAREFULLY
ABOV Semiconductor ("ABOV") reserves the right to make changes, corrections, enhancements, modifications, and
improvements to ABOV products and/or to this document at any time w ithout notice. ABOV does not give warranties as to the
accuracy or completeness of the information included herein. Purchasers should obtain the latest relevant information of ABOV
products before placing orders. Purchasers are entirely responsible for the choice, selection, and use of ABOV products and
ABOV assumes no liability for application assistance or the design of purchasers’ products. No license, express or implied, to
any intellectual property rights is granted by ABOV herein. ABOV disclaims all express and implied w arranties and shall not be
responsible or liable for any injuries or damages related to use of ABOV products in such unauthorized applications. ABOV and
the ABOV logo are trademarks of ABOV. All other product or service names are the property of their respective owners.
Information in this document supersedes and replaces the information previously supplied in any former versions of this document.
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